流水不争先,争的是滔滔不绝

An error occurred uploading to the iTunes Store.上传到App Store时出错

未分类 云聊IM 4200℃

最近两天打包上传App Store一直出错,而且看不到原因。尝试使用xcode9和application loader上传。

报错显示如下:

image1.png

image.png

日志信息是:

Right after upgrading to Xcode 9, I was trying to upload my app and got this error:

iTunes Store Operation Failed
An error occurred uploading to the iTunes Store.
No error was specified. I couldn't find a rumor for what went wrong.

So I exported the IPA and used Application Loader (Xcode->Open Developer Tool->Application Loader).

This time I got a bunch of very strange messages:

An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.asperasupport [5]: Unable to resolve 5.0: missing requirement [5.0] package; (&(package=com.apple.transporter.transport.service)(version>=1.9.6)(version<=1.9.6)) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.util.backoff)(version>=4.1.0)(!(version>=5.0.0)))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.asperasupport [6]: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=com.apple.transporter.transport.service)(version>=1.9.3)(version<=1.9.3)) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=com.apple.itunes.epubtoolkit)(version>=1.0.4)(version<=1.0.4))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.commlink [7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=com.apple.transporter.foundation)(version>=1.9.6)(version<=1.9.6)) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.util.backoff)(version>=4.1.0)(!(version>=5.0.0)))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.itmstransporter [8]: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.util.backoff)(version>=4.1.0)(!(version>=5.0.0)))
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.itmstransporter [9]: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=com.apple.itunes.epubtoolkit)(version>=1.0.4)(version<=1.0.4))
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.mediatoolkit [12]: Unable to resolve 12.0: missing requirement [12.0] package; (&(package=com.apple.itunes.epubtoolkit)(version>=1.0.4)(version<=1.0.4))
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.softwaresupport [13]: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=com.apple.transporter.log)(version>=1.9.6)(version<=1.9.6)) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.util.backoff)(version>=4.1.0)(!(version>=5.0.0)))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.softwaresupport [14]: Unable to resolve 14.0: missing requirement [14.0] package; (&(package=com.apple.jingle.leghorn.fileformat)(version>=1.9.3)(version<=1.9.3)) [caused by: Unable to resolve 12.0: missing requirement [12.0] package; (&(package=com.apple.itunes.epubtoolkit)(version>=1.0.4)(version<=1.0.4))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.updater [15]: Unable to resolve 15.0: missing requirement [15.0] package; (&(package=com.apple.transporter.log)(version>=1.9.6)(version<=1.9.6)) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.util.backoff)(version>=4.1.0)(!(version>=5.0.0)))]
An error occurred while starting bundles for the software update process.  Transporter will try to continue.  Unresolved constraint in bundle com.apple.transporter.updater [16]: Unable to resolve 16.0: missing requirement [16.0] package; (&(package=com.apple.transporter.log)(version>=1.9.3)(version<=1.9.3)) [caused by: Unable to resolve 9.0: missing requirement [9.0] package; (&(package=com.apple.itunes.epubtoolkit)(version>=1.0.4)(version<=1.0.4))]
An error occurred while trying to start the updater service. Exception's name: java.lang.NullPointerException, Exception's message: serviceReferences parameter cannot be null
An error occurred while trying to start transporter. Exception's name: java.lang.NullPointerException, Exception's message: serviceReferences parameter cannot be null

原因是因为Mac的Java版本更新导致

解决办法

在终端执行下面三条指令:

  1. 1、cd ~
  2. 2、mv .itmstransporter/ .old_itmstransporter/
  3. 3、"/Applications/Xcode.app/Contents/Applications/Application Loader.app/Contents/itms/bin/iTMSTransporter"

终端执行完毕,重现打开xcode打包上传就可以了

版权声明:部分文章、图片等内容为用户发布或互联网整理而来,仅供学习参考。如有侵犯您的版权,请联系我们,将立刻删除。
点击这里给我发消息